BreiteSeites Blog

home impressum

Netgear MR814v2 als Access Point in Betrieb

21 Mar 2009

So,

nachdem mein Bruder nun einen Router organisiert hat, welcher auch als Access Point dienen kann, hab ich nun diesen in Betrieb genommen. Nun haben wir wenigstens im oberen Stockwerk ein WLAN zur Verfügung.

Vorgehensweise ist wie folgt (unter Linux):

  1. Als allererstes ist die Datei /etc/resolv.conf zu sichern. (cp /etc/resolv.conf ~/resolv.conf).
  2. Nun den Router zum Strom verbinden und mit einem straight-through-Kabel zum eigenen Rechner.
  3. Über 192.168.0.1 kann man das Interface aufrufen (Anmerkung: Das Interface funktioniert mit einem aktuellen Opera Browser leider stabiler, als mit einem aktuellen Firefox-Browser (3.0.7).
  4. Unter Basic Settings ist der Punkt "Nein" bei  "Does Your Internet Connection Require A Login" zu wählen.
  5. Da unser Router über die 192.168.178.1 (255.255.255.0 Subnet) erreichbar ist, hab ich dem Access-Point ersteinmal gesagt, er solle doch bitte die 192.168.178.2 als IP benutzen, damit beide sich im gleichen Subnet befinden (Advanced -> LAN IP Setup -> LAN TCP/IP Setup) IP Address: 192.168.178.2 IP Subnet Mask: 255.255.255.0 RIP Direction: Both RIP Version: RIP_2B Achtung: Der Router trennt nach dem Klick auf Apply die Verbindung und meldet sich mit der neuen IP-Adresse an.
  6. Falls man schon DHCP ausgeschaltet hat, sollte man sich nun unter Linux mit "ifconfig eth0 192.168.178.20" erstmal eine IP aus dem Addressbereich geben. Danach kann man den Router über seine neue IP-Adresse 192.168.178.1 wieder "ansurfen"
  7. Im Menü aus Punkt 4 ist der Haken bei "Use Router as DHCP Server" zu entfernen, da die FRITZ!Box bereits über DHCP die IP-Adressen vergibt.
  8. Unter Advanced -> Wireless Setup nun noch "Enabled Wireless Access Point" und "Enabled SSID Broadcast" aktivieren.
  9. Unter Advanced -> WAN Setup sollte man noch "Connect Automatically, as Required" abwählen.
  10. Nicht vergessen: Unter Setup -> Wireless settings noch seine eigenen WLAN-Einstellungen vornehmen (SSID, Verschlüsselung, ...)
Das sollte auch schon alles gewesen sein. Den Rest kann man nach belieben konfigurieren und/oder damit herumbasteln. :-)

Netzwerkkabel abziehen, zurück an den "alten Switch". Jetzt mit einem zusätzlichen straight-through Kabel den Access-Point mit dem Switch verbinden und schon sollte man WLAN + Internet haben. Falls nicht, einfach nochmal kurz Strom abziehen. :-)

Es ist möglich, dass man in seinem alten Netzwerk plötzlich keine IP-Adresse auflösen kann. Dazu einfach die /etc/resolv.conf wiederherstellen oder mit 'echo "nameserver 192.168.178.1" >> /etc/resolv.conf' (bzw. die IP eures Router/Gateways) den entsprechenden Eintrag hinzufügen.

Tipp:

Man kann den Router (MR814v2) mit der neueren Firmware des nächsthöheren Modells MR814v3 "updaten" um so z.B. zusätzlich WPA-Verschlüsselung freizuschalten. Ich hab das gemacht und bis jetzt funktioniert alles weiterhin wie gewohnt (allerdings auch erst 30 Minuten in Betrieb mit der neuen Firmware). Allerdings empfehle ich dringend, die letzte MR814v2 Firmware auf dem Rechner bereitzuhalten, im Falle es funktioniert nicht und/oder man hat keine Internet-Verbindung mehr.